$re = '/^(?:.+_|)water_glass$/m';
$str = 'xxxx_water_glass
water_glass';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);