using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[pP]{2}[^a-m](?!.*(.).*\1)\d{5}$";
string input = @"ppt92613
ppy92619
ppt92617
PPr99999k";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}