use strict;
my $str = '1x21y3333333313333';
my $regex = qr/1x|1.*/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";