# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*?array\(('.*?)\), [^\)]+'\);.*/$1/gm;t' <<< "drupal_add_js(array('my_common' => array('my_code_validate' => variable_get('my_code_validate', FALSE), 'inner_index2 => 'inner_value2'), 'another_item' => 'another_value'), 'setting');"