const regex = /.*?array\(('.*?)\), [^\)]+'\);.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?array\\((\'.*?)\\), [^\\)]+\'\\);.*', 'gm')
const str = `drupal_add_js(array('my_common' => array('my_code_validate' => variable_get('my_code_validate', FALSE), 'inner_index2 => 'inner_value2'), 'another_item' => 'another_value'), 'setting');`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);