use strict;
my $str = 'drupal_add_js(array(\'my_common\' => array(\'my_code_validate\' => variable_get(\'my_code_validate\', FALSE), \'inner_index2 => \'inner_value2\'), \'another_item\' => \'another_value\'), \'setting\');';
my $regex = qr/.*?array\(('.*?)\), [^\)]+'\);.*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";