#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-9])(\1)0$"
Local $sString = "/* MATCH */" & @CRLF & _
"110" & @CRLF & _
"220" & @CRLF & _
"330" & @CRLF & _
"440" & @CRLF & _
"550" & @CRLF & _
"660" & @CRLF & _
"770" & @CRLF & _
"880" & @CRLF & _
"990" & @CRLF & _
"/* NO MATCH */" & @CRLF & _
"000" & @CRLF & _
"111" & @CRLF & _
"2201" & @CRLF & _
"9900" & @CRLF & _
"10100" & @CRLF & _
"100" & @CRLF & _
"010" & @CRLF & _
"120" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")