use strict;
my $str = '/* MATCH */
110
220
330
440
550
660
770
880
990
/* NO MATCH */
000
111
2201
9900
10100
100
010
120
';
my $regex = qr/^([1-9])(\1)0$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}