use strict;
my $str = '/** Get ID */
$(\'#aaa\').show();
/** Get class */
$(\'.bbb\').hide();
/** Get IDs and classes and ignore other symbols */
$(\'#ccc.ddd > .eee\').empty();
/** Ignore other string but catch IDs and Classes*/
$(\'div #fff.ggg .hhh\').addClass(\'iii jjj kkk\');
/** Test multiple seletor in the same line */
$(\'#lll.mmm\').$(\'#nnn.hhh\');
/** Weird selector */
$(\'#yo-lo-how_are_you\');
/** Final test */
$(\'#test\').removeClass(\'caris avane aoi\').addClass(\'shirone teameow\');';
my $regex = qr/(?:(?:\$|\$_|\.(?:find|prependTo|closest))\(\'|(?<!^)\G)\s?([.#][-\w]+)?[^()\s.#]*(?=[^()]*\))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}