# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?:\$|\$_|\.(?:find|prependTo|closest))\(\'|(?<!^)\G)\s?([.#][-\w]+)?[^()\s.#]*(?=[^()]*\))"
test_str = ("/** Get ID */\n"
"$('#aaa').show();\n\n"
"/** Get class */\n"
"$('.bbb').hide();\n\n"
"/** Get IDs and classes and ignore other symbols */\n"
"$('#ccc.ddd > .eee').empty();\n\n"
"/** Ignore other string but catch IDs and Classes*/\n"
"$('div #fff.ggg .hhh').addClass('iii jjj kkk');\n\n"
"/** Test multiple seletor in the same line */\n"
"$('#lll.mmm').$('#nnn.hhh');\n\n"
"/** Weird selector */\n"
"$('#yo-lo-how_are_you');\n\n"
"/** Final test */\n"
"$('#test').removeClass('caris avane aoi').addClass('shirone teameow');")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.