const regex = /(?:\d[ -]*?){13,16}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\d[ -]*?){13,16}\\b', 'g')
const str = `9999 - 9999 - 9999 - 9
9999 - 9999 - 9999 - 99
9999 - 9999 - 9999 - 999
9999 - 9999 - 9999 - 9999
999 - 999 - 999 - 999 - 999
99-99-99-99-99-99-99
9-9-9-9-9-9-9-9-9-9-9-9-9
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}