package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:http:\/\/)?www.liveleak.com\/view\?i=(\w{14})`)
var str = `www.liveleak.com/view?i=3f5_1213987712
http://www.liveleak.com/view?i=3f5_1213987712`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}