// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?:http:\/\/)?www.liveleak.com\/view\?i=(\w{14})").unwrap();
let string = "www.liveleak.com/view?i=3f5_1213987712
http://www.liveleak.com/view?i=3f5_1213987712";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}