Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
([+]*)([0-9]+)(([,])([0-9]+))*
/
gm
Input 1
1
New
+000123,456 +123 000123,456 123 +123.45 -123,45
Substitution
$2${3:+.$5:}
+000123,456 +123 000123,456 123 +123.45 -123,45