import Foundation
let pattern = #"([+]*)([0-9]+)(([,])([0-9]+))*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+000123,456
+123
000123,456
123
+123.45
-123,45
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2${3:+.$5:}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)