const regex = new RegExp('(?!$)[123]{0,1}\\d(\\.\\d{1,2})(?!(\\s){0,3}%)', 'gm')
const str = `14.2
1.5
1002
4.3
6.3%
32.1 %
\$100`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}