use strict;
my $str = 'This is (321) an example.
(321) also
including (321) //basically not possible, but can\'t hurt.
this (321) has another group with a p: 122p
this (321) has another group with a I: 123i
this x235 should be ignored cause (123) is what i want to match.
(123) is what i want, not x111 or 125p or 999i
in this 111 case there is no solution 555
101 202.something
';
my $regex = qr/(?:\b[\s]?|[^x])([\d]{1}[\d]{2})(?:[^pi]|[\s]?\b)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}