import Foundation
let pattern = #"(?:\b[\s]?|[^x])([\d]{1}[\d]{2})(?:[^pi]|[\s]?\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
This is (321) an example.
(321) also
including (321) //basically not possible, but can't hurt.
this (321) has another group with a p: 122p
this (321) has another group with a I: 123i
this x235 should be ignored cause (123) is what i want to match.
(123) is what i want, not x111 or 125p or 999i
in this 111 case there is no solution 555
101 202.something
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)