package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(url="[^"]+")`)
var str = `<code url="http://ns.adobe.com/textLayout/2008"><p>"test"</p></code>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}