$re = '/CC\K[a-zA-Z0-9]+(?=DD)/';
$str = 'CCdatadfhdfghata1DD
CC3DD
CCdatazxczxczxczxdata3DD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);