import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<headers>.*)[\\r\\n][\\r\\n](?P<content>.*)";
final String string = "------WebKitFormBoundary3JCHTJWwvnOcvnSv\n"
+ "Content-Disposition: form-data; name=\"_format\"\n\n"
+ "json\n"
+ "------WebKitFormBoundary3JCHTJWwvnOcvnSv\n"
+ "Content-Disposition: form-data; name=\"rid\"\n\n"
+ "1\n"
+ "------WebKitFormBoundary3JCHTJWwvnOcvnSv\n"
+ "Content-Disposition: form-data; name=\"avatar\"; filename=\"carlingford.jpg\"\n"
+ "Content-Type: image/jpeg\n\n\n"
+ "���p�� \n"
+ "��T!1\"AQa2q�#B�� R�$3b�C���%r�4S�&�5c\n"
+ "Ds��'ET�d6U��� ��L!1AQaq\"��2����#��BR�b$3r����C%4S��s�&5DTc���?�g������F΅%v9��Ge�9�С@#B�'�y�4!p|hPW%<�8�:n��9�hI�B;�Ж�:R{�8Ћ(�m�:m�*����0��vƄ#��?'B���BQ����BGo}\n"
+ ";#�a#�΄U��W�x?�E��H��:��#Ռ�t�L�6C�u ��#�R����22����n�c���B�@3ƅ\"��ZRN�dv΄�����Д��pB��'B]�rҥ�����Q���)P�� �R�����R9Y�I&��� =���X?�bI�u��ĮQ���!C�'dn�}��-n�s�j8 �c$����Q����$�q��� �@�J9$ryԁj�pN�9���B8+*��v�Sih�J}[�W��ґ���R�r�?��h�I�J!�P�?J��+��T���+��Q�)�m\n"
+ "od";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}