$re = '/\d{2}-(January|February|March|April|May|June|July|August|September|October|November|December)-\d{4}/i';
$str = 'fdsfdf04-February-2016 fdfs';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);