#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[0-9]+(?=[^"]+"<)"
Local $sString = "Bonjour,<br><br>Voici le numéro de téléphone de <strong>*NAME*</strong>" : 0980653935 France"<br>" & @CRLF & _
" <br>Son adresse email est la suivante : heya1234@gmail.com<br>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")