import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]+(?=[^\"]+\"<)";
final String string = "Bonjour,<br><br>Voici le numéro de téléphone de <strong>*NAME*</strong>\" : 0980653935 France\"<br>\n"
+ " <br>Son adresse email est la suivante : heya1234@gmail.com<br>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}