const regex = new RegExp('[0-9]+(?=[^"]+"<)', 'g')
const str = `Bonjour,<br><br>Voici le numéro de téléphone de <strong>*NAME*</strong>" : 0980653935 France"<br>
<br>Son adresse email est la suivante : heya1234@gmail.com<br>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}