import re
regex = re.compile(r"[0-9]+(?=[^\"]+\"<)")
test_str = ("Bonjour,<br><br>Voici le numéro de téléphone de <strong>*NAME*</strong>\" : 0980653935 France\"<br>\n"
" <br>Son adresse email est la suivante : heya1234@gmail.com<br>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")