re = /[0-9]+(?=[^"]+"<)/
str = 'Bonjour,<br><br>Voici le numéro de téléphone de <strong>*NAME*</strong>" : 0980653935 France"<br>
<br>Son adresse email est la suivante : heya1234@gmail.com<br>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end