using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"а?$";
string substitution = @"о";
string input = @"Скопирована";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}