#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\bAssert\.Equal\(\K\h*((?(R)[^()]*(?:\((?1)\)[^()]*)*|[^,()]*(?:\((?1)\)[^(),]*)*))\h*,\h*((?1))\h*(?=\))"
Local $sString = "Assert.Equal(false, General.CashFactor.IsHighlighted());" & @CRLF & _
"Assert.Equal(values, General.CashFactor.GetValue());" & @CRLF & _
"Assert.Equal(int.Parse(General.Time.Hour.GetValue()), this.GetLocalTimeEN(int.Parse(timezone.Timezone2.Zeitverschiebung), int.Parse(hour)));"
Local $sSubst = "\2, \1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)