re = /([^"]*(?:"[^"]+"[^"]*)+[^"]*)(["])?/m
str = 'title:"no spacing before" and text breaks title:"no spacing before" and text breaks " after this'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result