package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(` \$adminvalues\s*=\s*
"
\(
[^,]+,\s*
'[^']+',\s*
MD5\('[^']+'\),\s*
'[^']+',\s*
'[^']+',\s*
\d,\s*
\d,\s*
\d\s*
\)
";`)
var str = `$adminvalues = "(NULL, 'Admin12345', MD5('Admin12345'), 'Admin12345', 'Admin12345', 5, 0, 0)";`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}