use strict;
my $str = '{ "list" :
[
{
"id" : 123,
"name" : "some name",
"description" : "Lorem ipsum",
"logo_image_url": "222.png",
"content_image_url" : "1355.png"},
{
"id" : 123,
"name" : "some other name",
"description" : "Lorem ipsum",
"logo_image_url": "111.png",
"content_image_url" : "1355.png"
}
]
}';
my $regex = qr/("(?:logo_image_url|content_image_url)"\s*:\s*)".*?"/p;
my $subst = '\\1""';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";