import Foundation
let pattern = #""\s*function\(.*\)(?:\\"|[^"])*""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{
"kay": "function() {
return 'hello \n fun
ction stuff'; }",
"key": "function() { return 'hello function stuff'; }",
"koy": "function() { return
\"hello function stuff\"; }"
"function(lll) { return 'hello
gfgf
jgjg
hfghg
function stuff'; }"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)