$re = '/[١٢٣٤٥٦٧٨٩]{4,}/';
$str = '١|٢|٣٣٣٣٣|٤٥٥٥|٥|٦|٧|٨|٩';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;