#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*?(myApp)"
Local $sString = "Line 1: myApp.name;" & @CRLF & _
"Line 2: myApp.version" & @CRLF & _
"Line 3: myApp.defaults, myApp.numbers;"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)