package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?(myApp)`)
var str = `Line 1: myApp.name;
Line 2: myApp.version
Line 3: myApp.defaults, myApp.numbers;`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}