const regex = /^.*?(myApp)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?(myApp)', 'gm')
const str = `Line 1: myApp.name;
Line 2: myApp.version
Line 3: myApp.defaults, myApp.numbers;`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);