const regex = /^(myApp.[a-zA-Z0-9].*?\b).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(myApp.[a-zA-Z0-9].*?\\b).*$', 'gm')
const str = `myApp.ComboPlaceHolderLabel,
myApp.GridTitleLabel);
myApp.SummaryLabel + '</b></div>');
myApp.NoneLabel + ')') + '</label></div>';`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);