$re = '/(?=.*[0-9].*[0-9].*[0-9])(?=.*[A-Z].*[A-Z].*[A-Z])[A-Za-z0-9]{8,30}/m';
$str = 'aaaaaSaaSasAd212D
gfgfdgdSSSdsad3f3
dfsdfsfdf3fsdfsfF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);