const regex = /((?=.*[A-Z]{1,})(?=.*\d{1,})(?=.*[^A-Za-z0-9]{1,})(?=.*[a-z]{1,})){8,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?=.*[A-Z]{1,})(?=.*\\d{1,})(?=.*[^A-Za-z0-9]{1,})(?=.*[a-z]{1,})){8,}', 'gm')
const str = `a
aaa
aaaaaaaa
zaq1@WSX
ZAQ!2wsx
11111111
========
@@@@@@@@`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}