package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(https?:\/\/)([a-zA-Z0-9]+)\.(example.com\/product\/)([a-zA-Z0-9]+)(\/shop)\/?`)
var str = `http://a.example.com/product/table/shop/
http://b.example.com/product/shoe/`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}