const regex = /(https?:\/\/)([a-zA-Z0-9]+)\.(example.com\/product\/)([a-zA-Z0-9]+)(\/shop)\/?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/)([a-zA-Z0-9]+)\\.(example.com\\\/product\\\/)([a-zA-Z0-9]+)(\\\/shop)\\\/?', 'g')
const str = `http://a.example.com/product/table/shop/
http://b.example.com/product/shoe/`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);