re = /\w*NewTree\w*|([a-zA-Z]+)/m
str = 'NewTree
BoostKite
SetTree
foobar
ComeNewTree'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end