#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=\pL),(?!\s)"
Local $sString = "Hello,there = Hello, there" & @CRLF & _
"Hello, there = Hello, there" & @CRLF & _
"He said,"Hi." = He said, "Hi."" & @CRLF & _
""
Local $sSubst = ", "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)