#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=Discount\s)\d+(\.\d+)?"
Local $sString = "Discount 7.5%" & @CRLF & _
"Discount 15%" & @CRLF & _
"Discount 10%" & @CRLF & _
"Discount 5.433%" & @CRLF & _
"fee 11%"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)