re = /(?<=Discount\s)\d+(\.\d+)?/
str = 'Discount 7.5%
Discount 15%
Discount 10%
Discount 5.433%
fee 11%'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result