#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[[:space:]]*([_[:alnum:]]*)[[:space:]]*=[[:space:]]*((.*?)[[:space:]]+([_[:alnum:]]+[[:space:]]*=[[:space:]]*.*))"
Local $sString = "key1 = what' ever the value key2 = the value Nb.2 key3= "last value""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")