package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[۰۱۲۳۴۵۶۷۸۹]+$`)
var str = `123456
۰۱۲۳۴۵۶
۰۱۲۳۴۵٦`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}