# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)\s*^[0-9]{4}-[0-9]{2}-[0-9]{2}.*"
test_str = ("Line 1\n\n"
"1234-23-22 Some text\n"
"More text")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.