import Foundation
let pattern = #"(?m)\s*^[0-9]{4}-[0-9]{2}-[0-9]{2}.*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Line 1
1234-23-22 Some text
More text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)